How To Install ri1.8 on CentOS 8

In this tutorial, we will discuss How To Install ri1.8 on CentOS 8 using dnf and yum package managers. Also, we will demonstrate how to uninstall and update ri1.8 as well.

One-liner Install Command

If you are only interested in the installation command, here is a quick answer for you:

sudo yum makecache && sudo yum -y install ruby1.8
or if you use dnf:
sudo dnf makecache && sudo dnf -y install ruby1.8

But if you are interested in the details with step-by-step instructions, the following information will be helpful.

What is ri1.8 and How to Install It?

First things first, you will need access to a server or computer running CentOS 8. This guide was written specifically with a server running CentOS 8 in mind, although it should also work on older, supported versions of the operating system.

Also, make sure you are running a regular, non-root user with sudo privileges configured on your server. When you have an account available, log in as your non-root user to begin.

There are several ways to install ri1.8 on CentOS 8. You can use (links are clickable):

In the following sections, we will describe each method in detail. You can choose one of them or refer to the recommended one.

Install ri1.8 on CentOS 8 using dnf

First, update dnf packages database with dnf by running the next command:

sudo dnf makecache --refresh

After updating database, You can install ri1.8 using dnf by running the following command:

sudo dnf -y install ruby1.8

Install ri1.8 on CentOS 8 using yum

Because ri1.8 is available in CentOS 8’s default repositories, it is possible to install it from these repositories using the yum packaging system.

To begin, update local packages database with yum using the following command.

sudo yum makecache --refresh

Now can install ri1.8 package on your server/computer by running the following command:

sudo yum -y install ruby1.8

How to upgrade (update) a single package ri1.8 using yum?

To update all the packages available on the system:

yum update

If you want to update a specific package like ri1.8 in this example you should use the following command:

yum update ruby1.8

To downgrade a package to an earlier version:

yum downgrade ruby1.8

How to Upgrade ri1.8 on CentOS 8 with dnf?

When you run the dnf update, all system packages with available updates are updated. However, if you want to upgrade a single package, then you would have to pass the package name as the argument to the dnf update command.

dnf update ruby1.8

How To remove ri1.8 from CentOS 8

To uninstall only the ri1.8 package you can execute the following command:

sudo dnf remove ruby1.8

Extra info and code examples

Ruby is the interpreted scripting language for quick and easy object-oriented programming. It has many features to process text files and to do system management tasks (as in perl). It is simple, straight-forward, and extensible. This package provides version 1.8 series of Ruby. On Debian, Ruby 1.8 is provided as separate packages. You can get full Ruby 1.8 distribution by installing following packages. ruby1.8 ruby1.8-dev ri1.8 ruby1.8-examples libtcltk-ruby1.8

  • Maintainer: unknown
  • Sources url: unknown
  • Section/Category: unknown

Conclusion

You now have a full guide on how to install ri1.8 using dnf and yum package managers. Also, we showed how to update manually as a single package and different ways to uninstall the ri1.8 from CentOS 8.

See also:

How To Install ri1.8 on CentOS 8

How To Install ri1.8 on Fedora 34

How To Install ri1.8 on Debian 11

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z